用yum升级nginx

系统默认的nginx的版本是1.10.x,这个版本 是有漏洞的,所以我们必须升级到最新版,但yum自身的软件仓库没有保护新版的nginx,所以我们需要修改一下yum的配置

/etc/yum.repos.d/nginx.repo

内容如下:

[nginx]
name=nginx repo
baseurl=http://nginx.org/packages/mainline/centos/7/$basearch/
gpgcheck=0
enabled=1

添加了软件仓库了,执行常规的升级方法就可以了

yum update nginx

或者是新安装

yum install -yum nginx
Sidebar